[GUIDA] Aggiungere permessi ADB con Linux

Discussione in 'Modding Stonex One' iniziata da lucky76, 4 Set 2015.

Condividi questa Pagina

  1. lucky76

    lucky76 Developers

    Iscritto:
    8 Set 2010
    Messaggi:
    780
    "Mi Piace":
    236
    Per chi usa Linux e ha problemi con adb con questo errore

    adb devices





    Sempre da Terminale con riga di comando
    lanciare la seguente linea:

    Codice:
    sudo gedit /etc/udev/rules.d/51-android.rules
    Mettete la vostra password di linux

    Si aprirà un file in cui dovrete aggiungere questa linea

    Salvate il file e chiudetelo.

    Ora in teoria vi riconoscerà il device StonexOne.
     
    Ultima modifica: 30 Gen 2016
    A Sandro Caputo, kalel77, mantra e 1 altro utente piace questo messaggio.
  2. rupiosh

    rupiosh Baby Droid

    Iscritto:
    2 Dic 2015
    Messaggi:
    4
    "Mi Piace":
    0
    Ciao, ho seguito la tua procedura.
    Se io da terminale uso il comando:
    # ./adb devices #
    mi viene restituito
    #0123456789ABCDEF device#
    che, se non sbaglio, significa che il telefono viene riconosciuto correttamente, quando uso il comando
    #adb reboot recovery#
    mi viene restituito
    #error: device not found#
    sapresti spiegarmi il perchè?
    Grazie dell'attenzione
     
  3. simoscorpion

    simoscorpion Administrator Membro dello Staff

    Iscritto:
    26 Lug 2012
    Messaggi:
    45.604
    "Mi Piace":
    11.830
    Prova
    ./adb reboot recovery

    Inviato dal mio SM-G928F utilizzando Tapatalk
     
    A lucky76 piace questo elemento.
  4. rupiosh

    rupiosh Baby Droid

    Iscritto:
    2 Dic 2015
    Messaggi:
    4
    "Mi Piace":
    0
    Funziona, grazie mille!
     
  5. simoscorpion

    simoscorpion Administrator Membro dello Staff

    Iscritto:
    26 Lug 2012
    Messaggi:
    45.604
    "Mi Piace":
    11.830
    Tutti i comandi di adb e fastboot au Linux sono preceduti da ./ tienilo presente per il futuro

    Inviato dal mio SM-G928F utilizzando Tapatalk
     
    A lucky76 piace questo elemento.
  6. rafee74

    rafee74 Baby Droid

    Iscritto:
    29 Gen 2016
    Messaggi:
    10
    "Mi Piace":
    0
    Io dando il comando indicato non ricevo nessun risultato:
    # adb devices
    List of devices attached

    e il file indicato da modificare l'ho compilato così (seguendo anche altre guide):
    #MediaTek
    SUBSYSTEM==”usb”, ATTR{idVendor}==”0e8d”, MODE=”0666″, GROUP="plugdev"

    Uso Ubuntu 14.04 su due portatili diversi e ho lo stesso problema su entrambi.