Il Forum è consultabile solo in modalità lettura. Per domande o consigli iscriviti al nostro GRUPPO FACEBOOK / COMMUNITY cliccando qui

installazione JAWA - Eclipse - ADT

Discussione in 'Development' iniziata da socio, 18 Apr 2014.

Condividi questa Pagina

  1. socio

    socio Baby Droid

    Iscritto:
    18 Apr 2014
    Messaggi:
    4
    "Mi Piace":
    0
    salve a tutti,

    mi sono riproposto di provare a iniziare a sviluppare qualcosa in proprio con Android.
    Così seguendo istruzioni ho scaricato i vari software necessari; purtroppo ho provato ad installare quanto indicato sul mio pc con XP sp3 installato, e non riesco andare avanti.

    provo a riassumere sperando in qualche gradito suggerimento:
    1) ho scaricato l'ultima versione del JDK che mia hanno suggerito funzionare con XP (jdk-7u55-windows-i586) e l'ho installata;
    2) ho impostato l'ulteriore variabile d'ambiente JAVA_HOME=C:\Programmi\Java\jdk1.7.0_55

    ma quando provo a fare doppio click sul Eclipse.exe (eclipse-java-kepler-SR2-win32), dopo la il logo splash del programma compare una maschera di errore che allego, e il programma si interrompe. eclipse.jpg
    La cartella di Eclipse va posta in una dir particolare del PC?

    cosa ho sbagliato?

    grazie, Socio
     
  2. socio

    socio Baby Droid

    Iscritto:
    18 Apr 2014
    Messaggi:
    4
    "Mi Piace":
    0
    chiedo scusa se .... busso alla porta ....

    ma non riesco nemmeno a iniziare la mia esperienza con Andoid

    a qualcuno è capitato un esperienza simile, oppure riesce a capire dal printscreen perchè Eclipse non parte? che mancherà?

    chiedo ancora scusa , ma ...

    un saluto, Socio
     
  3. Hhaunted

    Hhaunted Baby Droid

    Iscritto:
    24 Ott 2012
    Messaggi:
    15
    "Mi Piace":
    6
  4. socio

    socio Baby Droid

    Iscritto:
    18 Apr 2014
    Messaggi:
    4
    "Mi Piace":
    0
    grazie per l'attenzione Hhaunted

    ho ricontrollato ma le versioni sono tutte 32bit, tra l'altro, mi pare che sul mio XP non sia proprio possibile installare versioni di software a 64bit.

    ho provato ad aggiungere il \bin nella variabile ambiente e nulla cambia.

    ho provato a leggere l'articolo che hai citato ma non mi pare che aggiunga altro alle possibili cause; ho lanciato il comando Java -version, e mi restituisce:
    java version 1.7.0_55
    java se runtime enviroment build 1.7.0_55-b13
    hotspot client VM build 1.7.0_55-b13 mixed mode, sharing

    qualche suggerimento ulteriore?

    un saluto, Socio
     
  5. Hhaunted

    Hhaunted Baby Droid

    Iscritto:
    24 Ott 2012
    Messaggi:
    15
    "Mi Piace":
    6
    stavo rileggendo l'errore. C'è scritto "-Dosgi.requiredJavaVersion=1.6". Tu hai 1.7. Installa la 1.6 32bit. Controlla anche di avere installato jre 1.6 o 1.7
     
  6. socio

    socio Baby Droid

    Iscritto:
    18 Apr 2014
    Messaggi:
    4
    "Mi Piace":
    0
    è stata una delle prime cose che ho pensato, ma sul sito la vers. non era disponibile: la 1.7 era l'ultima utilizzabile su XP.
    cmq ho spostato la cartella di Eclipse sotto \programmi e il prog. è partito anche se poi mi sono impantamnato con la configurazione di ADT, sdk ecc.


    vedremo