Il Forum è consultabile solo in modalità lettura. Per domande o consigli iscriviti al nostro GRUPPO FACEBOOK / COMMUNITY cliccando qui

messaggio strano in cwm

Discussione in 'Samsung Galaxy S II / PLUS' iniziata da 2 p1000, 30 Set 2017.

Condividi questa Pagina

  1. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Buongiorno a tutti,
    come sicuramente tanti di noi, il mio passatempo preferito è "smanettare".
    Da qualche giorno ho per le mani questo telefono e, naturalmente, una delle prime cose che ho fatto è stata modificargli il PIT (l'ho portato a 6gb).
    Fin qui tutto bene e funzionava benissimo, ma, naturalmente, non potevo accontentarmi e ho seguito tutta la procedura per installare la cwm. Quando finalmente dopo non so quanti tentativi al punto che non mi ricordo più come ho fatto ci sono riuscito, ho scaricato, per provare, qualche rom in formato .zip e l'ho copiata nella sd esterna. In breve, devo essermi incasinato nei vari wipe (un'altra volta imparo a fare le cose lle 3 della notte) e l'installazione si blocca dandomi il messaggio:
    Warning: No file_contextsThis package is for device: galaxy2,i9100,GT-I9100M,GT-I9100P,GT-I9100T,SC-02C; this device is .
    E:Error in /sdcard/Resurrection-Remix-LP-v5.5.9-20151120-i9100.zip
    (Status 7)
    Installation aborted.
    Mi dà l'impressione come se non riconoscesse il telefono (ho evidenziato in grassetto quale, secondo me è l'origine del problema, cioè "this device is" senza essere seguito da nessun nome).
    Uscendo, il telefono... (mi sembra denigrante chiamarlo così) allora, lo smartphone, si blocca sulla schermata nera con la scritta "Samsung GALAXY S II GT-I9100" ed il triangolo giallo con punto esclamativo.
    Da questa schermata posso andare in recovery e, usando la combinazione dei tasti per andare in downloads mode, anche se la schermata non cambia, odin lo vede (il riquadro diventa giallo).
    Allora, ho provato a flashare varie rom (stock e non) sia con cwm che con odin ottenendo sempre lo stesso risulta: il messaggio di cui sopra da cwm e "fail" da odin.
    Qualcuno ha qualche suggerimento per uscire da questo inghippo?
     
  2. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Abbiate pazienza, dimenticavo di specificare che il mio è un s2 gt-i9100.
     
  3. Phil Stelar

    Phil Stelar Golden Droid

    Iscritto:
    13 Feb 2016
    Messaggi:
    6.083
    "Mi Piace":
    3.819
    Hai incassato sicuramente le partizioni, se non sbaglio riconfigurare con il PIT può essere fatto solo su rom stock, e non sulle custom.

    A questo punto ciò che ti consiglio di fare è quello di flashare via Odin il firmware stock+il PIT originale della memoria dello smartphone.

    Dopo potrai nuovamente decidere se andare di custom o modificare con un PIT diverso.

    Inviato dal mio Nexus 5X utilizzando Tapatalk
     
  4. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Grazie Phil Stelar, ma come ho detto nel messaggio, dopo aver modificato il PIT (con installata una rom stock) lo smartphone funzionava benissimo e le memorie risultavano modificate come volevo. Il problema è venuto dopo, quando, dopo aver fatto la procedura per l'installazione della CWM (andata a buon fine), facendo i wipe devo aver cancellato per sbaglio qualcosa che riguarda il nome del dispositivo per cui CWM non lo riconosce più.
    Bravo, vero?:)
     
  5. Phil Stelar

    Phil Stelar Golden Droid

    Iscritto:
    13 Feb 2016
    Messaggi:
    6.083
    "Mi Piace":
    3.819
    Esatto, il problema è venuto dopo, perché la riconfigurazione della partizione e il flash della CWM sono andate bene. Il problema giustamente si è presentato dopo, quando hai tentato di flashare una custom su delle partizioni non native.
    Il problema dello smartphone non riconosciuto è un problema della CWM adesso.
    Tu devi invece rifare da zero tutto tramite Odin+PIT originale, capito?

    Inviato dal mio Nexus 5X utilizzando Tapatalk
     
  6. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Qualche link?...
     
  7. Cristian

    Cristian Power Droid

    Iscritto:
    25 Feb 2013
    Messaggi:
    14.769
    "Mi Piace":
    5.672
  8. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Niente da fare!
    Ad un certo punto (non sto a scrivere dall'inizio):
    <ID:0/006> File analys..
    <ID:0/006> SetupConnection..
    <ID:0/006> Complete(Write) operation failed.
    <OSM> All threads completed. (Succeed 0 / failed 1)
    Che dici, ci sono strade via recovery?
     
  9. Cristian

    Cristian Power Droid

    Iscritto:
    25 Feb 2013
    Messaggi:
    14.769
    "Mi Piace":
    5.672
    prova via recovery a fare un wipe data, poi spegni il cell e riavvialo in download mode, riprova con odin v1.85 a flashare il firmware stock + file pit da 16 GB o quello mod da 4gb che trovi nella guida sopra. se ricevi altri errori da odin , riprova il flash del FW utilizzando un altro cavo usb.

    Inviato dal mio LEX820 utilizzando Tapatalk
     
    A 2 p1000 piace questo elemento.
  10. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Secondo me qualcosa non va nel collegamento con odin, infatti si blocca sempre su "SetupConnection.."
    Allora ho provato a collegarlo accendendolo e basta e odin lo vede lo stesso, (come ho scritto nel primo post schermata nera con la scritta "Samsung GALAXY S II GT-I9100" ed il triangolo giallo con punto esclamativo). Forse io "pensavo" di andare in download mode dato che odin lo vede, ma evidentemente, anche facendo nel modo corretto la sequenza dei tasti, dato che la schermata è la solita e quindi non cambia nulla ed anche se odin lo vede (casella diventa gialla con numero della porta) non c'è scambio di informazioni.
    Comunque (e scusa la mia ignoranza), secondo me la soluzione sarebbe dare in pasto alla cwm uno script in formato .zip che gli permettesse di riconoscere l's2
    A proposito: grazie per l'interessamento (anche se so che in fondo in fondo è questo il divertimento)
     
  11. Cristian

    Cristian Power Droid

    Iscritto:
    25 Feb 2013
    Messaggi:
    14.769
    "Mi Piace":
    5.672
    Cmq se hai flashato una recovery cwm di vecchia data e hai provato ad installare una custom ROM su base KitKat o lollipop.. l'errore che ricevi da quella cwm quando vai flashare lo zip della ROM lerrore (status 7) è perché o hai una recovery non compatibile per quelle ROM oppure lo zip della ROM è corrotto. dovresti provare a riscaricare la rom che vuoi flashare e riprovare oppure provare ad aggiornare la recovery con la cwm per le rom KitKat e lollipop che trovi la guida in sezione modding.

    Inviato dal mio LEX820 utilizzando Tapatalk
     
  12. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Risolto!!!
    Ti ringrazio, Cristian, ma non essendo convinto, ho provato a fare così:
    dunque, non trovando il sistema per adattare la cwm alla rom (fantascienza?) mi sono detto: ma perchè non cercare di adattare la rom alla cwm (più umano)?
    Così con 7zip l'ho scompattata e con Notepad++ (e tanta pazienza) ho editato ad uno ad uno i file in cerca di quello che indirizzava la rom al dispositivo. Nella cartella META-INF/com/google/android c'era un file che si chiamava updater-script che, una volta editato, aveva tutta una riga lunga un chilometro e mezzo (la prima) in cui appariva quello che a me pareva essere l'elenco dei dispositivi compatibili con quella rom. In modo molto deciso (facendo gli scongiuri, toccando ferro e su un piede solo) e con mano ferma (si fa per dire considerando il lavoro fatto fino ad allora) l'ho eliminata tutta. Ricompattata (sempre con 7zip), copiata in microsd e... tutto ok!
    Si fa per dire...
    Le gapps non ci vanno (neanche le pico)
    E allora ho formattato il system con un PIT (visto che c'ero: abbondiamo) da 1,5GB (fonte xda).
    Risultato: ho messo le gapps "full"! :peace:
     
  13. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Notizie dell'ultima ora:
    tanto per spasso, ho installato il pacchetto gapps "super": ok.
    Quindi ora ho:
    Rom "Resurrection-Remix-LP-v5.5.9"
    Pacchetto Gapps installato: "Super"
    Versione di Android 5.1.1

    Inviato col mio "redivivo" GT-I9100
     
  14. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Abbiate pazienza, non è per incrementare il numero dei post, solo che volevo avvisare che, visto che ora funziona tutto, ricomincio daccapo con qualche altro SO
    Grazie a quelli intervenuti e, se ci fosse bisogno per ogni chiarimento, sono a disposizione. :thumb:
     
  15. 2 p1000

    2 p1000 Baby Droid

    Iscritto:
    21 Mar 2017
    Messaggi:
    31
    "Mi Piace":
    4
    Meno di un'ora, e non so se dire per fortuna o purtroppo (perchè è già finito il divertimento) e sull'S2:
    Android 7.1.2
    Rom OCT-N-M2-20170825-i9100
    Gapps "Stock" (702,05MB il file zip)
    (Per la verità ho provato prima con le "Super", ma non ci sono entrate (chissà come mai, forse perchè sono 859.82MB?)
    Prossimo obbiettivo: togliere il triangolo giallo senza disinstallare la custom.
    Si parte con la ricerca...