Il Forum è consultabile solo in modalità lettura. Per domande o consigli iscriviti al nostro GRUPPO FACEBOOK / COMMUNITY cliccando qui

[GUIDA] [Nexus Modding] puntata 3 | Aggiornamenti OTA

Discussione in 'Guide modding' iniziata da MatteoV, 6 Mar 2014.

Condividi questa Pagina

  1. Alessandro Caputo

    Alessandro Caputo Baby Droid

    Iscritto:
    31 Mag 2013
    Messaggi:
    20
    "Mi Piace":
    0
  2. MatteoV

    MatteoV Moderator Membro dello Staff

    Iscritto:
    28 Feb 2013
    Messaggi:
    967
    "Mi Piace":
    837
    Quando sei in fastboot non riesci a farlo vedere dal PC? Quello non dipende dai file sul telefono, ma dai driver del PC. Devi solo configurarli correttamente.
    Segui questa guida http://www.tuttoandroid.net/forum/g...astboot-drivers-15-seconds-adb-installer.html.
    Qui guida alternativa con anche la configurazione delle variabili d'ambiente.

    Quando sei riuscito a farlo riconoscere dal PC in fastboot (metti in fastboot, collega e digita "fastboot devices". Dovrebbe uscirti un codice che identifica il dispositivo) segui questa guida per l'installazione della factory image senza perdere i dati.
     
  3. MatteoV

    MatteoV Moderator Membro dello Staff

    Iscritto:
    28 Feb 2013
    Messaggi:
    967
    "Mi Piace":
    837
    assolutamente si :)
     
  4. Alessandro Caputo

    Alessandro Caputo Baby Droid

    Iscritto:
    31 Mag 2013
    Messaggi:
    20
    "Mi Piace":
    0
    Possibile disattivarlo temporanemante? O fare un backup? E' un casino se perdo le configurazioni dei moduli =(
     
  5. Vyolance

    Vyolance Baby Droid

    Iscritto:
    20 Mar 2014
    Messaggi:
    9
    "Mi Piace":
    0
    Ciao Marco,
    non credo siano i driver visto che fino ad un secondo prima di aver fatto la guida indicatami il collegamento funzionava correttamente, sia con adb che con fastboot...
    Solo dopo aver fatto il format /system non mi fa + vedere il device (che rimane nella schermata iniziale di Google, dove c'è il lucchetto della root per intenderci..).
    Lanciando "abd devices" sembra lo veda...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached

    Mentre con fastboot non mi restituisce nulla...

    Ora provo a seguire le tue guide, ma per quanto riguarda i driver io avevo già seguito la tua guida che indicafa anche l'installazione dei pacchetti di SDK (adb, fastboot e driver google)

    [HR][/HR]

    Ciao Marco,
    i driver dovrebbero essere a posto...infatti prima di fare l'utima guida consigliatami che faceva un format /system funzionava tutto correttamente utilizzando i driver google installati utilizzando una delle tue guide..per personalizzarmi il cell ho usato tutte le tue "lezioni" e tutto ha sempre funzionato.
    Cmq per sicurezza ho reinstallato i driver google, ma senza seguire la guida che mi hai messo te nell'utimo post (perche non ho capito se c'è qualcosa di diverso rispetto a quello che ho fatto..e poi non è molto chiara..) ho utilizzato il vecchio metodo utilizzando SDK Tool
    Il cell continua a non essere visto da fastboot e adb, la porta USB è riconosciuta.

    Hai altre idee??

    [HR][/HR]

    Ciao Marco,
    ho fatto tutto quello che hai scritto ma ancora non riesco a far vedere il device al PC...
    Ho anche reinstallato tutto
    Ho provato senza nulla e putroppo ancora non funziona.
    chiaramente la seconda parte, recuperare da factory image stock non è possibile farla...sia adb devices che fastboot devices non rispondono..!
    Hai altre idee??

    Ciaoooo e grazie in anticipo
     
    Ultima modifica di un moderatore: 10 Giu 2014
  6. MatteoV

    MatteoV Moderator Membro dello Staff

    Iscritto:
    28 Feb 2013
    Messaggi:
    967
    "Mi Piace":
    837
    si, entra in xposed installer e disinstalla il framework. (i moduli non verranno toccati).
    Fai l'aggiornamento e poi reinstalli xposed installer, dopo di chè ri-abiliti il framework e ti ritroverai già tutti i moduli.
    Dovrebbe funzionare..ma non posso assicurartelo al 100% perchè non ho mai provato.
     
  7. MatteoV

    MatteoV Moderator Membro dello Staff

    Iscritto:
    28 Feb 2013
    Messaggi:
    967
    "Mi Piace":
    837
    Mi chiamo Matteo :eek:

    dunque, un paio di cose:
    1- dove hai letto di fare un format system? per gli aggiornamenti OTA non è da fare assolutamente.
    2- adb e fastboot sono due cose ben diverse. I comandi di adb funzionano con telefono acceso normalmente oppure in recovery. I comandi di fastboot funzionano solo ed esclusivamente in fastboot. Ora, quello che ti serve è solamente fastboot, quindi devi assicurarti di avviare il dispositivo in fastboot (da spento premi volume - e tasto power contemporaneamente). Una volta avviato in fastboot puoi provare a dare il comando "fastboot devices". Il codice che ti dovrebbe uscire è formato da numeri e lettere (una decina). List of device attached esce quando provi a dare il comando adb devices e i driver non sono corretti.
    Se già questa cosa per te è ovvia ti prego di scusarmi, ma per poterti dare una mano devo capire esattamente cosa stai provando a fare :)
     
  8. Alessandro Caputo

    Alessandro Caputo Baby Droid

    Iscritto:
    31 Mag 2013
    Messaggi:
    20
    "Mi Piace":
    0
    Non ha funzionato. Comunque ho risolto levando xposed, custom kernel e root. Ho flashato boot system e radio. Dopodichè ho rimesso il root, kernel e xposed =)
     
  9. Vyolance

    Vyolance Baby Droid

    Iscritto:
    20 Mar 2014
    Messaggi:
    9
    "Mi Piace":
    0
    Ciao MATTEO!!!!
    Scusa la distrazione :D
    Sei sempre chiarissimo!! Appena posso faccio un altro tentativo e ti faccio sapere!
    Scusa il multipost, ma pensavo non mi facesso postare ed ho riscritto + volte! sono un disastro! uhm

    Grazieeeeeeeee

    Ciaoo
     
  10. Vyolance

    Vyolance Baby Droid

    Iscritto:
    20 Mar 2014
    Messaggi:
    9
    "Mi Piace":
    0

    Ciao Matteo!!!
    Ho riprovato e ci sono riuscito grazie a te!!
    Ero un pollo io!! Pensavo che fastboot potesse riuscire a vedere il device in fase di boot....

    Grazie come al solito!!!!

    Ciaoooooooooooooo
     
  11. Daneel85

    Daneel85 Baby Droid

    Iscritto:
    18 Giu 2014
    Messaggi:
    5
    "Mi Piace":
    0
    Ok, scusate il disturbo, vorrei farvi qualche domanda, sperando abbiate la pazienza di rispondere.

    Per poter usare alcuni programmi ho abilitato la root sul mio nexus 5; preso dall'entusiasmo qualche giorno fa sono passato a ART; quindi ho fatto l'aggiornamento a 4.4.3 tramite OTA.
    Adesso ho visto che i programmi non hanno più permesso di Root.

    Immagino sia dovuto all'aggiornamento; per poter riavere nuovamente i permessi di root, devo installare nuovamente la custom recovery e SuperSu, giusto?
    Oppure ho danneggiato qualcosa e devo fare un altro procedimento?
     
  12. MatteoV

    MatteoV Moderator Membro dello Staff

    Iscritto:
    28 Feb 2013
    Messaggi:
    967
    "Mi Piace":
    837
    Tranquillo, nessun danno! Il root consiste in un file che viene installato direttamente nella partizione di sistema, con l'aggiornamento sia la partizione di sistema che quella di recovery sono state riscritte per cui hai sia perso root che custom recovery. Per riottenere entrambe le parti, ripeti le stesse operazioni che hai compiuto la prima volta :). Se hai bisogno di altre info siamo qui ;)
     
  13. Daneel85

    Daneel85 Baby Droid

    Iscritto:
    18 Giu 2014
    Messaggi:
    5
    "Mi Piace":
    0
    Ti ringrazio per la celerità, non me l'aspettavo :)

    Leggendo le pagine precedenti, ho capito che nel caso di un futuro aggiornamento mi converrà scaricarlo esternamente, caricarlo su memoria e farlo partire dal bootloader; ho capito bene?
     
  14. MatteoV

    MatteoV Moderator Membro dello Staff

    Iscritto:
    28 Feb 2013
    Messaggi:
    967
    "Mi Piace":
    837
    In verità l'operazione che citi non differisce dal flash automatico dell'ota. Il processo è lo stesso, ma aggiornando automaticamente non ti accorgi dei vari passaggi.
    Piuttosto una cosa conveniente è quella di non flashare proprio l'OTA e di installare la nuova factory image pulita ;)
     
  15. Daneel85

    Daneel85 Baby Droid

    Iscritto:
    18 Giu 2014
    Messaggi:
    5
    "Mi Piace":
    0
    Capito, grazie.
     
  16. webmasterone

    webmasterone Baby Droid

    Iscritto:
    30 Giu 2011
    Messaggi:
    12
    "Mi Piace":
    1
    si, lo so che è stato detto migliaia di volte, ma vvorrei essere sicuro per non sbagliare
    ho un Nexus 5 con Bootloader sbloccato, Root e Custom Recovery (TWRP)
    Versione attuale 4.4.3 build KTU84M
    Xposed Installato con una decina di moduli attivi
    Boot Animation cambiato con uno personalizzato (bootanimation.zip)


    seguendo le istruzioni qui (Android 4.4.4 arriva su Nexus 5 via OTA: download e guida – Tutto Android) vorrei fare :

    1) downlaod del file OTA: c08cce45be6d759d6fd29480f01128b18f7d4a11.signed-hammerhead-KTU84P-from-KTU84M.c08cce45.zip
    2) salvarlo nella memoria del dispositivo
    3) Riavviare in recovery, Flashare e Riavviare

    Secondo voi ?

    1) non dovrei avere problemi ?
    2) non perdo il root ?


    problemi:

    problema Xposed, ho letto più su che è consigliabile non a verlo installato ?
    allora ho fatto il backup di xposed con Titanium backup
    lo disinstallo
    flasho l'OTA
    lo restoro da titanium
    dovrei riavere l'Xposed e tutti i moduli ? corretto ?


    Più sopra avete scritto:
    Benissimo, ti fai un bel backup con adb, poi ripristini completamente il dispositivo tramite factory image (vedi puntata 1), dopo di chè aggiorni. Dopo che hai aggiornato ripristini il backup e avrai il telefono come prima dell'aggiornamento ma con la nuova versione installata. Tempo totale di queste operazioni? 10/15 minuti..ma anche meno!

    avete scritto qualche guida passo passo per fare questo ?

    scusate tutte le domande, ma come detto, la paura di sbagliare e trovarmi il telefono non avviabile è tanta.....
     
  17. sex110182

    sex110182 Baby Droid

    Iscritto:
    14 Dic 2010
    Messaggi:
    43
    "Mi Piace":
    1
    anche io ho ho un Nexus 5 con Bootloader sbloccato, Root e Custom Recovery (TWRP)
    Versione attuale 4.4.3 build KTU84M
    Xposed Installato con una decina di moduli attivi
    montata la cyanogen 11

    se volessi installare da recovery il file ota da 2,5mb basterebbe o andrebbe tutto in tilt?
    grazie
     
  18. MatteoV

    MatteoV Moderator Membro dello Staff

    Iscritto:
    28 Feb 2013
    Messaggi:
    967
    "Mi Piace":
    837
    ho aggiunto una parte alla guida al primo post che risponde a tutte le domane. Sul backup scusa ma ti rispondo tra poco, ora devo proprio scappare.

    ho aggiunto una parte alla guida in OP che risponde alle tue domande.

    PS: se hai installata una custom ROM NON puoi assolutamene installare un OTA! Devi avere il fw stock.
     
  19. webmasterone

    webmasterone Baby Droid

    Iscritto:
    30 Giu 2011
    Messaggi:
    12
    "Mi Piace":
    1
    ciao, solo una segnalazione
    nella sezione della guida "Come risolvere i problemi legati alle condizioni precedenti?"
    hai scritto :Qui la guida completa per installazione e configurazione di Android SDK.
    ma non hai linkato la guida
    :)
     
    A MatteoV piace questo elemento.
  20. MatteoV

    MatteoV Moderator Membro dello Staff

    Iscritto:
    28 Feb 2013
    Messaggi:
    967
    "Mi Piace":
    837
    fixato ;)