[ROOT] Permessi di Root con MobileGO

Discussione in 'Modding - Huawei Mate 7' iniziata da elia_11, 9 Giu 2015.

Condividi questa Pagina

  1. elia_11

    elia_11 Silver Droid

    Iscritto:
    19 Dic 2012
    Messaggi:
    4.986
    "Mi Piace":
    1.382
    ATTENZIONE : NE' IO NE' TUTTOANDROID CI ASSUMIAMO RESPONSABILITA' IN CASO DI EVENTUALI DANNI ARRECATI AL VOSTRO DISPOSITIVO



    Grazie alle segnalazioni di alcuni nostri utenti condivido un metodo alternativo per ottenere i permessi di Root . La procedura è molto semplice e non richiede lo sblocco del bootloader .


    1) Scaricate e installate il programma MobileGO sul vostro pc Windows : MobileGO


    2) Collegate il telefono al PC tramite cavo USB .


    3) Aprite il programma MobileGO . Cliccate sulla voce "Controlla Privacy" , successivamente sulla voce "Occorre Root" presente in fondo alla pagina e poi date la conferma all' operazione . Aspettate che la procedura finisca , dopodichè dovrebbe comparire una finestra che vi dice che la procedura è andata a buon fine . Per ulteriori conferme scaricate app del tipo Root Checker e verificate il possesso dei permessi di Root -> FINE .



    Si ringrazia per la segnalazione : lukrezio e anakin71
     
    Ultima modifica: 9 Giu 2015
  2. manoto

    manoto Baby Droid

    Iscritto:
    24 Lug 2010
    Messaggi:
    16
    "Mi Piace":
    0
    Ma è per caso necessaria una versione particolare di MobileGO?
    Ho letto nell'altra discussione che la versione che sembra aver funzionato sia la 5.3.1
    Grazie in anticipo
     
  3. macrosf

    macrosf Honorary Member

    Iscritto:
    13 Nov 2012
    Messaggi:
    3.035
    "Mi Piace":
    651
    Esiste una versione a pagamento,con tutte le funzioni attive.
     
  4. manoto

    manoto Baby Droid

    Iscritto:
    24 Lug 2010
    Messaggi:
    16
    "Mi Piace":
    0
    ho scaricato ed installato l'applicazione dal link riportato in prima pagina.
    Installato i driver del MT7-TL10
    Seguita la procedura del primo post

    Cliccate sulla voce "Controlla Privacy". Far eseguire il controllo. Successivamente dovrebbe essere presente in fondo alla pagina "Occorre Root".
    Conferma dell'operazione.

    Lo smartphone si riavvia, ma "root non riuscito".

    Ho provato 3 volte.
    Qualche suggerimento?
     
  5. elia_11

    elia_11 Silver Droid

    Iscritto:
    19 Dic 2012
    Messaggi:
    4.986
    "Mi Piace":
    1.382
    Riprova , gli altri utenti anche non ci sono riusciti a prima botta . Da cosa dipenda non saprei , probabile dal programma stesso

    Inviato da Mountain View
     
  6. manoto

    manoto Baby Droid

    Iscritto:
    24 Lug 2010
    Messaggi:
    16
    "Mi Piace":
    0
    Come suggerito, ho provato molte altre volte ma il risultato non cambia.
    Credo che il problema non sia residente nel programma stesso.
    In ogni caso, vediamo se altri felici possessori del Mate riescono con questo metodo.
    Grazie comunque del supporto
     
  7. macrosf

    macrosf Honorary Member

    Iscritto:
    13 Nov 2012
    Messaggi:
    3.035
    "Mi Piace":
    651
    Serve il Debug attivato,con huawei di solito funziona,se non va alla prima insisti.
     
  8. manoto

    manoto Baby Droid

    Iscritto:
    24 Lug 2010
    Messaggi:
    16
    "Mi Piace":
    0
    Ovviamente il debug era attivo.
    Credimi... ho provato parecchie volte... ma niente.

    Girando su internet ho trovato un'altra procedura che dovrebbe eseguire il root del mate senza lo sblocco del BL.

    XDA - [ROOT] Mate 7 Root Without BL Unlock

    Qualcuno ha notizie su tale procedura?
    Sembra funzionare con gli LT10 e non ancora per gli LT09
     
  9. elia_11

    elia_11 Silver Droid

    Iscritto:
    19 Dic 2012
    Messaggi:
    4.986
    "Mi Piace":
    1.382
    Non la conosco . Vediamo cosa dice chi l'ha fatta con MobileGO

    Inviato da Mountain View
     
  10. anakin71

    anakin71 Baby Droid

    Iscritto:
    7 Giu 2015
    Messaggi:
    3
    "Mi Piace":
    2
    Allora chiarisco la mia esperienza. Io avevo installato nel mio pc solo hisuite di huawei. Come specificato da Lukrezio, ho installato la versione 5.3.1 di MobileGo perchè con le successive Lukrezio aveva avuto esito negativo.
    All'apertura di MobileGo ho la schermata che allego. In alto a sinistra si vede il mio mate 7 Gold perfettamente riconosciuto e sulla destra c'è un bottone con la dicitura "Root in un clic".
    Io ho cliccato e dopo qualche minuto il telefono si è riavviato e mi è comparsa sul pc la schermata di root avvenuto con successo. Ci tengo a precisare che io ho collegato il telefono al pc in modalità File Manager dispositivo (MTP) e non pc suite (HiSuite).
    Adesso, da smanettone, sono indeciso se aggiornare a lollipop. Essendomi iscritto come betatester ho ricevuto la notifica dell'update ma ho paura che aggiornando perderei il root e non sono sicuro che si possa fare un downgrade.
    Spero di essere stato utile, per ulteriori info sono quì ;)

    Nuova immagine bitmap.jpg
     
  11. manoto

    manoto Baby Droid

    Iscritto:
    24 Lug 2010
    Messaggi:
    16
    "Mi Piace":
    0
    Dal link del primo post si scarica MobileGo 5.3.1 ma la schermata non è uguale alla tua.
    Non allego l'img perchè ho disinstallato tutto
    Per il resto la procedura che ho eseguito è la stessa ma con esito opposto al tuo.

    questa la procedura per abilitare il tasto "Occorre Root" con la versione 5.3.1 presa dal link nel primo post
    --Cliccate sulla voce "Controlla Privacy". Far eseguire il controllo. Successivamente dovrebbe essere presente in fondo alla pagina "Occorre Root".
    --Conferma dell'operazione.
    --Lo smartphone si riavvia, ma "root non riuscito".

    A questo punto ti chiedere, se posso, dove posso scaricare la versione che hai utilizzato tu.

    Grazie in anticipo
     
  12. anakin71

    anakin71 Baby Droid

    Iscritto:
    7 Giu 2015
    Messaggi:
    3
    "Mi Piace":
    2
    Non ricordo dove lo recuperai a suo tempo, non posso nemmeno scriverti in pm perchè ci vogliono 50 post.
    Se mi dai una mail posso scriverti li.
     
  13. elia_11

    elia_11 Silver Droid

    Iscritto:
    19 Dic 2012
    Messaggi:
    4.986
    "Mi Piace":
    1.382
    Se devi spiegare come hai fatto con MobileGO puoi farlo tranquillamente qui

    Inviato da Mountain View
     
  14. manoto

    manoto Baby Droid

    Iscritto:
    24 Lug 2010
    Messaggi:
    16
    "Mi Piace":
    0
    Ciao anakin,
    mi puoi scrivere al mio nick aggiungendo gmail.com

    In ogni caso, sempre in rete, ho trovato diversi post che dichiaravano che si riusciva ad effettuare il root sul mt7-l10 anche con kingo root.
    Ieri sera mi sono dilettato e di fatti adesso ho il root.
    Le verifiche con RootChecker hanno dato esito positivo e di fatti sono riuscito ad installare apk che tipicamente richiedono un device con root.

    La versione di kingo root che sembra funzionare è l'ultima scaricata direttamente dal loro portale.
    Ho scaricato il tool per windows e dopo le solite operazioni di installazione, riconoscimento del device con installazione dei relativi drivers, ho eseguito le semplici istruzioni riportate a monitor e in qualche minuto l'operazione di root è andata a buon fine.
    Unica accortezza è che dopo la scritta di "Root Successfully" bisogna riavviare a mano il Mate prima di fare le verifiche con RootChecker.

    Spero di essere stato di aiuto.
     
  15. lukrezio

    lukrezio Baby Droid

    Iscritto:
    29 Mag 2015
    Messaggi:
    15
    "Mi Piace":
    5
    Come scritto in altra discussione ho installato sia la versione MobileGo 7.3.1 che MobileGo Android 5.3.1
    Solo quest'ultima ha funzionato. Io li tengo installati entrambe perchè non vanno in conflitto e per gestire il telefono è più comoda la versione 7.6.1
    Ti allego le schermate. MG761.JPG MG531.JPG
     
  16. caarot

    caarot Baby Droid

    Iscritto:
    17 Ott 2012
    Messaggi:
    47
    "Mi Piace":
    0
    Ciao a tutti.. Con la guida postata da Elia sono riuscito a fare il root, ma non avendo boot sbloccato e recovery custom non mi fa aggiornare i binari su... Consigli?

    - - - - post aggiornato - - - -

    Ciao a tutti.. Con la guida postata da Elia sono riuscito a fare il root, ma non avendo boot sbloccato e recovery custom non mi fa aggiornare i binari su... Consigli?
     
  17. elia_11

    elia_11 Silver Droid

    Iscritto:
    19 Dic 2012
    Messaggi:
    4.986
    "Mi Piace":
    1.382
    Flasha semplicemente lo zip di SuperSu

    Inviato da Mountain View
     
  18. lukrezio

    lukrezio Baby Droid

    Iscritto:
    29 Mag 2015
    Messaggi:
    15
    "Mi Piace":
    5
    Non è così facile.... anche io ho lo stesso problema. Ho lo zip update, accedo alla recovery mode e... ecco le uniche cose che mi fa fare. (vedi foto) TPhoto_00002_rsz.jpg
     
  19. elia_11

    elia_11 Silver Droid

    Iscritto:
    19 Dic 2012
    Messaggi:
    4.986
    "Mi Piace":
    1.382
    Ah si giusto manca la custom recovery perché . Avete provata a flasharla come detto nell'altra guida ?

    Inviato da Mountain View
     
  20. lukrezio

    lukrezio Baby Droid

    Iscritto:
    29 Mag 2015
    Messaggi:
    15
    "Mi Piace":
    5
    Fin dall'inizio con questo telefono nulla fila liscio e semplice! Ho scaricato il file con la recovery_h60.img che si indicava appunto nella guida che poi diceva di flasharla tramite un file bat allegato. Eseguiti i passi indicati, prima 1 per flasharla, 3 per riavviare in recovery e .... anche se tutto avvenuto correttamente, riecco la schermata della recovery stock!!!:mad: Rifaccio.... nulla sempre li siamo. Allora come per il root ho cercato vie traverse e l'ho trovata in una App dal Play Store: Flashify. Con la stessa App prima ho fatto il Backup della recovery stock (non si sa mai) poi ho caricato il file immagine della recovery_h60.img sul mio dropbox visto che lo contempla (ma va bene anche nel telefono o SD) avvio Flashify vado in recovery image, gli indico il file immagine e fatto! Riavvio in recovery e tutto ok.... e procedo anche a flashare l'update dei binari di SU. Volendo si può fare il flash di un zip anche dalla stessa app.
    TPhoto_00001.jpg
    TPhoto_00007.jpg
     
    A elia_11 piace questo elemento.