Il Forum è consultabile solo in modalità lettura. Per domande o consigli iscriviti al nostro GRUPPO FACEBOOK / COMMUNITY cliccando qui

Problemi Bluetooth con Lollipop. Possibile soluzione!

Discussione in 'Samsung Galaxy Note 3' iniziata da trudtilp, 19 Apr 2015.

Condividi questa Pagina

  1. trudtilp

    trudtilp Baby Droid

    Iscritto:
    7 Lug 2011
    Messaggi:
    40
    "Mi Piace":
    8
    Salve a tutti


    Prima di aprire questa discussione mi sono fatto un giro e non ho trovato nulla di simile. Dunque vengo a portarvi la mia soluzione.
    Partiamo prima dal fatto. Da che ho aggiornato a Lollipop (aggiornamento ufficiale Italiano no brand) ho iniziato ad avere problemi su problemi col BT (abbrevio per praticità).
    A fine Gennaio ho comprato un bellissimo smartwatch e a prescindere che sia o meno una cosa utile io mi ci trovavo benissimo.... fino all'aggiornamento! Prima con la 4.4.2 nessun problema. Solo qualche casino di connessione quando si mischiavano diverse versioni di BT. Ad esempio, l'orologio e v4.0 e la macchina e v2.0. L'auricolare v2.1 e così via . Quando si connetteva qualcosa antecedente alla v3.0.... casini a go go. Ma per il resto tutto ok.
    Dopo l'aggiornamento Lollipop questi problemi erano di gran lunga i minori. La connessione BT durava minuti come stabilità e spesso mi capitava che ciò che connettevo, se lo spegnevo il telefono continuava a vederlo connesso e in molti casi auricolari o vivavoce della macchina anche se connessi non funzionavano.
    In poche parole, era diventato un incubo che mi ha portato al desistere dall'usare qualsiasi mio apparato BT. :cry:


    Da qui una riflessione... "ma perché quando ho provato la prima Leaked Lollipop uscita a fine Novembre non ricordavo tutti stì casini!?"
    Al che un lampo di genio (si fa per dire). E se usassi il modulo BT precedente?
    Premessa: I problemi BT riscontrati in Lollipop non sono tutta farina del modulo BT. Almeno a mio giudizio. Centra molto anche la gestione delle app in background (Samsung ha corretto fin da subito il Memory leaked di Lollipop e chi sa come) e un po' di colpe le ha anche l'App Google Android-Wear. Dunque non tutto si risolve.


    Comunque, avete letto fin qui e adesso la soluzione che sto provando da diverse ore e a mio giudizio mi ha risolto parecchi problemi.
    Cambiate la Base-Band del cellulare. Con cosa? Con quella della Leaked di fine novembre!
    Voi attualmente avete la N9005XXUGBOA1. Almeno, questa è quella installata sulla Rom Lollipop ITV no brand. La potete trovare qui per backup.
    CP_N9005XXUGBOA1.tar (55,01 MB) - uploaded.net MD5:161f231222cfb1a62fc9e3ebfc33749d
    Dovete installare la N9005XXUGBNL8 che era contenuta nella Leaked. La trovate qui.
    CP_N9005XXUGBNL8.tar (54,99 MB) - uploaded.net MD5:bf8645d1faab0cd1277fc09659410806
    Io le ho prese da XDA ma dato che non sapevo se poter o meno linkare una pagina del loro forum, ho preferito ricaricare da me i due pacchetti.
    La procedura è semplice
    Estraete i due file contenuti nel pacchetto compresso. "modem.bin" e "NON-HLOS.bin"
    Dovrete flashare entrambi con ODIN, dalla versione 3.09 in su.
    Mettete il telefono in Download Mode partendo da cellulare spento ovviamente (Volume giù + Home + Power).
    Aprite ODIN e caricate nella voce CP modem.bin. Togliete la spunta ad Auto Reboot e collegate il telefono al pc col cavo ORIGINALE che è sempre meglio!
    Avviate il flash col pulsante Start. Ci vorranno un paio di minuti neanche...
    Quando vedrete in ODIN che il flash è andato a buon fine (leggete "Passed" nella finestra Message in basso a sinistra) scollegate il cellulare dal PC e estraete la batteria.
    Mettete la batteria e il telefono in Download Mode nuovamente (Volume giù + Home + Power).
    Collegatelo al PC e in ODIN caricate alla voce CP NON-HLOS.bin e questa volta spuntate l'opzione Auto Reboot.
    Flashate nuovamente con Start e attendete che il telefono si riavvii da solo.
    Ecco fatto! Avete cambiato la Base-Band!
    Dalle mie prove funziona tutto perfettamente. WiFi, GPS, Telefono (LTE compreso) e il BT è tornato a funzionare nettamente meglio.
    Anzi! Io adesso non riscontro nemmeno più i casini fra diverse versioni di BT.
    Di certo non si risolve tutto per via di quel che ho scritto prima nella premessa ma parecchie cose Sì. Ve lo assicuro.
    Buon divertimento e grazie per aver avuto la pazienza di leggermi fin qui e fatemi sapere come vi trovate. Peggio non è possibile. ;)